Open .csv files don't work at first / change default selections



  • I’m having trouble to opening filename.csv files with Notepad ++
    No problems if the files are opened with the explorer, by finding the file / right click / select open with Notepad ++.
    But if I use (freely translated from Swedish) File / Open and “select a CSV-file” a question arises “can’t open… Do you want to create a new file?
    (In the window to the right of the selection of file name it stands Normal text file (.txt))
    But I can see all CSV-files files…
    If I make the selection All types It works. If I then make the selection Normal text file (.txt) again I only see filename.txt
    This feels like a program bug - only in my version?
    ( I have Win10, Notepad++ 7.7.1 64-bit Swedish )
    Is it possible to change the default selection to “all files” or better, only “.csv .skv .txt” files?



  • @Jan-Öhman

    could it be that npp and the explorer are started with different elevation levels?



  • “different elevation levels” What does it mean?



  • @Jan-Öhman

    It means that maybe your Explorer is open with administrator privilege and your Notepad++ is not.

    But, I’m not convinced that that is what the problem is. But we will see…



  • Thank you for your response. Don’t know what happened, but now it seems to be working.
    (made a choice between different file types …)
    Then I chose (All types *. *) Now it seems to work…

    In the beginning when opening a file, the file type was “Normal text file (* .txt)”, but also .csv files were displayed … (that’s when I got an error when opening the file …)

    Is it possible to change which file types are displayed in Notepad ++?
    (eg. not only *.txt files but also *.csv and *.skv files)



  • @Jan-Öhman said:

    that’s when I got an error when opening the file …

    It’s really doubtful that the filter settings had anything to do with the error you received.

    Is it possible to change which file types are displayed in Notepad ++?..not only *.txt files but also *.csv and *.skv files

    Probably not easy to get just those 3 types filtered.


Log in to reply