re-emergence of an old issue



  • The app has stopped appending ‘txt’ to saved text files.
    The issue occurred a few years ago.

    https://community.notepad-plus-plus.org/topic/10840/files-won-t-save-with-txt-extension



  • You could type the extra 4 characters, so that you are in control of the extension, rather than trusting that windows will deduce that you want .h whenever you save a C++ source file, rather than the sensible .cpp, just because .h is earlier in the list for that type.

    Or, if you really want to continue to use the dialog that Windows stopped recommending years ago, the solution from 4 years ago in that thread still works (toggling the setting in the default directory section of the prefs).



  • @PeterJones The point is, for a few years, I’ve used Notepad++ and the default extension has always been ‘.txt.’ Why change what is uneccessary to change. Whim? Neccessary change is good. Uneccessary change is a waste.



  • I don’t see that anything has changed. There was no change, on a whim or otherwise, of Notepad++'s behavior in this regard.

    I just downloaded fresh zip copies of v7.8, and 7.8.1-rc1.

    I loaded each, which contain Notepad++ at its default settings. Both, out of the box, were set to new-style dialog, so if I did a save and typed blah as the name, it created a file called blah (with no extension). If I changed the Settings > Preferences > Default Directory to disable ☐ Use new style dialog (without file extension feature & Unix style path capacity), which makes it use the “old-style”, then if I save and type blah, it creates blah.txt, which is the behavior you want.

    Both of these are correct behavior, and have been standard since v6.8.4, at least 4 years ago.

    If you have a new installation of Notepad++ (for example, on a new computer, or a fresh installation where you deleted your old settings), and the no-extension behavior “came back”, it’s for the same reason it happened to @justin-morabito in 2015: because Notepad++, out of the box, ships with the modern Windows-style dialog box enabled, like it has for four years. Because that’s the dialog that windows recommends. Because that’s the dialog that gives the user the most control. If you don’t like it, all you have to do is uncheck one checkbox. If you maintain the settings file through upgrades (and that’s the default behavior when upgrading Notepad++), your setting to use the old-style, force-the-extension-on-you dialog, it will stay selected until the settings get reset by you.



  • @PeterJones Thanks for the redirect. I read more closely and made the change.
    Thanks again.


Log in to reply