Tab settings not saving settings for "use default value"



  • @Daniel-Fuchs

    this seems to work for me as long as I’ve understand correctly what
    you are trying to achieve.

    Notepad++ v7.8.6   (64-bit)
    Build time : Apr 21 2020 - 15:23:03
    Path : D:\Tests\npp\_latest\x64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 7 Professional (64-bit) 
    OS Build : 7601.24544
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll 
    


  • @Ekopalypse

    I suppose what the OP was trying to point out with the redboxing was that the item was the only one that was altered.



  • @Alan-Kilborn

    Yes, I think/thought so too but to illustrate what he did it is needed, isn’t it?
    Seems I’m drawing a blank, again !? (not sure if this is the correct translation but sounds nice :-)



  • @Daniel-Fuchs ,

    As @Ekopalypse said, “it works for me”:

    Notepad++ v7.8.6   (64-bit)
    Build time : Apr 21 2020 - 15:23:03
    Path : C:\usr\local\apps\notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit) 
    OS Version : 1903
    OS Build : 18362.720
    Plugins : ComparePlugin.dll LuaScript.dll MarkdownViewerPlusPlus.dll mimeTools.dll NppConsole.dll NppConverter.dll NppEditorConfig.dll NppExec.dll NppExport.dll NppFTP.dll PreviewHTML.dll PythonScript.dll QuickText.dll XMLTools.dll 
    


  • @PeterJones thanks for your animation.

    That‘s my issue. It does not remain between sessions. Can you please point out, where this setting should be saved?



  • I do not run in LocalConfMode, whereas you both do…



  • @Daniel-Fuchs said in Tab settings not saving settings for "use default value":

    That‘s my issue. It does not remain between sessions.

    I can duplicate OP’s issue with fresh portable (Local Conf Mode : ON) N++ extraction:

    • Go in and untick Use default value for xml files.
    • Exit Notepad++
    • Upon restart, Use default value for xml is ticked again.

    So take heart, OP, I think that I agree with your findings!



  • @Alan-Kilborn

    I’m in local config mode:


    Notepad++ v7.8.6 (64-bit)
    Build time : Apr 21 2020 - 15:23:03
    Path : C:\usr\bin\npp64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 1809
    OS Build : 17763.1158
    Plugins : AnalysePlugin.dll AutoSave.dll BetterMultiSelection.dll ChangedLines.dll CodeAlignmentNpp.dll ColumnTools.dll ComparePlugin.dll CsvQuery.dll CustomizeToolbar.dll DoxyIt.dll DSpellCheck.dll Explorer.dll GitSCM.dll JSMinNPP.dll NppConsole.dll NppConverter.dll NppEventExec.dll NppExec.dll NppExport.dll NppFTP.dll NppMarkdownPanel.dll NppMenuSearch.dll PreviewHTML.dll Python Indent.dll QuickText.dll SpeechPlugin.dll SurroundSelection.dll TagLEET.dll XMLTools.dll ZoomDisabler.dll


    I use “Replace by space” “4” and only override that in Makefile:

    bc40da0e-9537-4cce-82e3-0f39d8c93576-image.png

    That always stays for me opening and closing N++ and through reboots.

    I think it stores it in $(NPP_INSTALL_DIR)\langs.xml

    PS MVINCENT ~ > grep tabSettings C:\usr\bin\npp64\langs.xml
            <Language name="makefile" ext="mak" commentLine="#" tabSettings="4" />
            <Language name="python" ext="py pyw" commentLine="#" tabSettings="-1">
            <Language name="yaml" ext="yml yaml" commentLine="#" tabSettings="-1">
    

    You’ll notice Python and YAML are also in there because in a default install, they use tab and I “override” them to used the default (which I set to convert to 4 spaces):

    1f4ccf2b-5764-4fa2-a10d-bf9437d77455-image.png

    Hope this helps?

    Cheers.

    PS: i LOVE pasting pictures directly into the new post text box!!!



  • @Alan-Kilborn said in Tab settings not saving settings for "use default value":

    So take heart, OP, I think that I agree with your findings!

    I no longer agree. :-(

    If one follows my earlier outlined procedure, they will (and I, finally) realize that what I did…does nothing. All I do is remove the “default” setting from being applied to XML files. Well…if the setting then left for XML files happens to match the “default”, what has been altered: NOTHING (that matters for the current discussion).

    Anyway, apologies for the confusion – seems to be working just fine for me now to save the settings between Notepad++ runs.



  • @Daniel-Fuchs

    goto %APPDATA% directory and rename notepad++ directory temporarily.
    Start npp, it will recreate new, with default settings set, config files.
    Do your changes and make your test to see if it keeps it settings.



  • Thank you all for your help.

    I then guess something is wrong with my langs.xml (on my work computer). The settings work just fine on my private computer. I’ll check on that and report back.

    If anyone is interested (thanks @Michael-Vincent for pointing this out), the property tabSettings in /NotepadPlus/Languages/Language is set to “-1” if the “Use default value” is use. When this checkbox is disabled the value is then determined by the configured tab size and is incremented by 128 if the “Replace by space” option is set.



  • Removing config.xml fixed the issue on my work computer.


Log in to reply