Notepad ++ .txt association keeps reverting to Windows Notepad



  • Hello All,

    First request for help here. I’ve searched and searched the forums and other sites. Everything I’ve tried isn’t working.

    Whenever I set Notepad ++ as the default .txt handler, Windows Notepad takes over after every reboot. I can’t figure out why.

    Here is what I’ve tried.

    • Notepad++ as administrator > Settings > Preferences > File Association
    • Shift+Right Click on .txt file > Open With > Choose Another App > Always use this app to open .txt files
    • Settings > Choose default apps by file type
    • command line > ftype Notepad++_file=“C:\Program Files\Notepad++\notepad++.exe” “%1”
    • command line > assoc .txt=Notepad++_file
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.txt\UserChoice

    I have NOT tried any third party programs to fix this and would prefer not to.

    I’ve got event viewer auditing looking for registry changes. I see that the HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.txt\UserChoice\ProgId registry entries Hash & ProgId is changed back to Windows Notepad. I can see that OpenWith.exe is making the change. I have no idea how or why this is being invoked, however.

    What am I missing here?

    How do I tell what may be causing this?

    How to I make this association ‘permanent’?

    Thanks in advance for any responses.

    Regards,

    Terry



  • @Terry-Musser,

    Sorry that’s happening to you. Windows 10 is annoyingly difficult to get stable file associations in. The NPP developers do their best to set the right registry settings, but sometimes there is a buried entry that gets in the way.

    this recent discussion talks some about registry locations that might be interfering with the association attempts – especially my final post. That might give you some pointers where to look next.


Log in to reply