Commandline Parameter -l <vb> or -l vb does not set the Language to VB



  • Hello to All!
    as a new Member Thomas:
    I tried to start noteped++ from a vb6 application using following cmd line:
    Private Sub CmdNotePad_Click()
    Dim x, AppNam, AppPar
    'AppNam = "C:\Program Files\Notepad++\notepad++.exe " '64bit
    AppNam = “C:\Program Files (x86)\Notepad++\notepad++.exe " '32bit
    AppPar = FN & " -<vb> -alwaysOnTop " '-openFoldersAsWorkspace”
    x = AppNam & AppPar
    Debug.Print x
    x = Shell(x, vbNormalFocus)
    End Sub

    C:\Program Files (x86)\Notepad++\notepad++.exe C:\Development\BK11T\clsDlg.cls -<vb> -alwaysOnTop

    any trick how I’ll get it running with VB Language instead of Normal?
    Thanks for Help



  • @Thomas-Habermann

    I would try: notepad++.exe myfile.ext -lvb

    That worked for me, to put this on the status bar when the file opened:

    934dbaef-1ff3-4701-8b40-2f3cfc31dd37-image.png

    Note that I don’t know or care what extension visual basic files use, so I just used .ext above.

    Also, I wasn’t out to debug your shell command in its entirety, just the part that seemed to be giving you trouble.

    BTW, the manual page for command line arguments is HERE … but it seems to have a problem, as it talks about “ghost typing” where the -l command line argument is described; this makes little sense…

    cf470b84-3f73-4c29-ab7a-a482115c4b17-image.png

    Of course, the ghost typing thing is of dubious sense…



  • @Alan-Kilborn
    Thanks for your msg! I can see the selected file correctly but just in “Normal” if I swith the Langage manually it works correctly as it should! Only the command line Parameter had no effect - I tried also -lvb earlier in the 64Bit version
    How ever, using -lvb works correctly now in the 32Bit version
    -SOLVED


Log in to reply