7.9.5 Not Appending extension to files with period in name



  • Previously in 7.9.4 I could have a file “test.123” and when the .txt extension was selected it would append that .txt extension to the file. Now having updated to 7.9.5 when I save a file with a period in the name such as “test.123” and .txt extension is selected it will just save as test.123 and ignore the extension. Is there something I need to adjust in the settings to correct this?





  • @Brian-D said in 7.9.5 Not Appending extension to files with period in name:

    in 7.9.4 I could have a file “test.123” and when the .txt extension was selected it would append that .txt extension to the file

    I cannot duplicate this result with 7.9.4.
    It acts identically AFAICT to 7.9.5.

    I haven’t checked the FAQ (yet), but I’d think that it believes your .123 is the extension you want file to have. Maybe it is trying to be smarter than you, but on the other hand, maybe not. :-)
    Isn’t the cure simple, I mean, for files of this sort, just type .txt at the end in the box prompting for a name?
    If you forget and it slips by you at that time, just rename the file to add the .txt (using File > Rename), as soon as you notice it?



  • @Alan-Kilborn Yah, the issue is doing bulk file saves for me in how I save a lot of text files at once. Not sure why it changed or when exactly, I know for the longest time it was working and just got the 7.9.5 update today so I can’t remember exactly which version I might have been on prior. I’ll probably try a clean install and see if that helps.



  • It looks like I was using 7.9.0 and 7.9.1 (I had a VM with 7.9.1 installed where it worked fine) which still had the old-style enabled and I updated from there. So I guess now I have to figure out how to force an extension when I save a file with a period which kind of stinks as I enjoyed having that auto append when I had a period in the file name.



  • @Brian-D said in 7.9.5 Not Appending extension to files with period in name:

    It looks like I was using 7.9.0 and 7.9.1

    You can always continue to use those versions.

    or the longest time it was working

    “working” is relative.
    Probably the developers think how it works now is also defined as “working”, maybe the “new working”.
    So…if you wait for it to be fixed, you may be in for a long wait.

    It is a bit of a strange situation, this automatic appending (or not) of extensions.

    Personally, my approach is to tick this setting:

    cdba3be3-9bce-462c-a324-05370f217dbd-image.png

    and then just add whatever extension I want to the file (by explicitly typing it) at SaveAs time.



  • @Alan-Kilborn Yup, I figure I’ll just turn off auto-update for now and continue to use the older versions. I did some reading and while it would be a nice enhancement to be able to always append a extension I kind of get why that’s not really in the “new style” moving forward. Perhaps one day that might get added but I’ll just stick to the older versions for now :)
    Thanks for the help by the way!



  • @Brian-D said in 7.9.5 Not Appending extension to files with period in name:

    to be able to always append a extension

    If you don’t have the checkmark that Alan showed enabled, then it does always add an extension… unless you’ve already typed something that looks like an extension, then it assumes you know best.

    Perhaps one day that might get added

    I doubt it. This is the new behavior, recently changed by user request. There are some tweaks regarding implementation coming (where that option will be located, etc)… but in general, the complaints with the old system, where someone would type blah.123 and complain because it did add .txt were what drove the improvement to what it currently does.

    The fact is, the developers can’t win. Every time they change something to make someone happy, someone else complains.



  • @Brian-D

    It’s somewhat of a crazy topic, but…

    Maybe what is needed is a 3 way setting:

    • never auto-add anything (I guess equivalent to the current “…filter to *.*” ticked)
    • always add the “filter type” extension (AFAIK no current equivalent exists)
    • do the “natural” thing (I guess equivalent to the current “…filter to *.*” unticked)


  • @Alan-Kilborn ,

    Better hurry: issue#9515 has PR#9732… Once that’s accepted, I doubt they’ll want a third option added.

    (Actually, I added a comment there to give a heads-up about your suggestion.)



  • @PeterJones said in 7.9.5 Not Appending extension to files with period in name:

    about your suggestion

    Heck, I don’t even know if it is a good suggestion.
    This setting doesn’t impact my work at all; it bothers me not one whit to type .txt or .cpp or .py or …
    I was just sort of throwing it out there for someone (@Brian-D ?) to grab onto if they’d like, to become its champion.



  • @Alan-Kilborn said in 7.9.5 Not Appending extension to files with period in name:

    always add the “filter type” extension (AFAIK no current equivalent exists)

    What is the value of this option? Should this be another option in settings?



  • @mere-human said in 7.9.5 Not Appending extension to files with period in name:

    always add the “filter type” extension (AFAIK no current equivalent exists)

    What is the value of this option?

    It seems like it is what the OP of this thread wants.
    And, in truth, it seems like this desire keeps recurring in postings on this site.

    Should this be another option in settings?

    I have no idea of the best implementation.
    I was just offering up some ideas, but unfortunately they were for something I would never ever use.
    And I don’t think you get the best opinion from someone about a feature they would never use.
    So, I must bow out gracefully from this. :-)

    But, it is getting tiresome, the continuous postings on this topic.
    First it was the infinite “old style” / “new style” dialog questions/problems.
    Then that went away, only to be replaced by this current conundrum.
    If you, @mere-human, are the one that can put an end to it, then maybe you are more than a mere human, indeed.



  • @Brian-D said in 7.9.5 Not Appending extension to files with period in name:

    I could have a file “test.123” and when the .txt extension was selected it would append that .txt extension to the file.

    Could you, please, provide more detailed scenario to reproduce the issue?
    I’ve just tried in Notepad++ 7.9.1 portable and couldn’t do that.
    What I did:

    • Turn off Preferences > Default Directory > Use new style dialog
    • Turn off Preferences > MISC. > Set Save dialog file extension filter to .*
    • File > New
    • File > Rename > “new.123”
    • Type some text to the document
    • File > Save As
    • .txt is not added, type is Normal text file
      05c690f0-ade4-4cb7-8224-2019c7d5bb52-image.png


  • @mere-human said in 7.9.5 Not Appending extension to files with period in name:

    Could you, please, provide more detailed scenario to reproduce

    What I did:

    .txt is not added

    Steps with 7.9.1 to make it do what the OP of this thread wants to have happen:

    • Extract 7.9.1 portable and run it
    • type some chars to modify the tab entitled new 1
    • Ctrl+s
    • type test.123 in the File name box
    • press Enter

    Result is: test.123.txt <— .txt is added

    c92d6c55-6421-4f8c-81ec-7dfb23a84159-image.png



  • @mere-human ,

    For my memory, I know that I used to see behavior where if Windows “knows” an extension like .123 (ie, listed in regedit HKEY_CLASSES_ROOT\.123), that if I typed blah.123 with text-file type, it would just use .123 as the extension. But I tried an extension that is not in the registry extension list, like .xyzzy, that typing blah.xyzzy would name the file blah.xyzzy.txt.

    I don’t have time right now to re-reproduce… but a quick search showed me https://community.notepad-plus-plus.org/post/56453, where I went into some detail on my experiments for when v7.8.9 would and would not add extensions



  • @Alan-Kilborn said in 7.9.5 Not Appending extension to files with period in name:

    Result is: test.123.txt <— .txt is added

    Oh, I see! Thank you.
    Then, as for me, it looks like another regression in the new Save As dialog.
    File dialogs were changed changed in 7.9.3 in scope of #9374.
    So I’d just fix it to behave like in 7.9.1 (append file extension for the mentioned case).



  • @mere-human said in 7.9.5 Not Appending extension to files with period in name:

    So I’d just fix it to behave like in 7.9.1 (append file extension for the mentioned case).

    I can’t really tell but it sounds from that like you think this is easy. :-)
    Many have tried to “fix” this behavior for everyone’s need – many have to this point in time apparently failed.
    Please, whatever you do, find some way to make this the end of this pain. :-)



  • This post is deleted!


  • @Brian-D Do you have this Hide extensions option ON by any chance?
    de64cd6e-f60b-4671-9ca8-89c2638c82b1-image.png


Log in to reply