Help with dark mode.



  • Hi there,
    Setting up “Dark Mode” over preferences only makes the toolbar/titlebar black, not the editor itself. Totally useless.

    notepadd++.png

    How to make everything black?

    Running on Windows 10 with Dark colors enabled.

    Thanks so much!



  • @Matheus-Bitencourt

    For me, when I tick Enable dark mode checkbox on the Dark Mode page of the Preferences, everything “goes dark”:

    9007117c-ed01-4f9d-ac08-69230a133ee5-image.png

    Not sure what you might be doing differently.


    Of course, you can override the dark theme for the editor by doing something like this (selecting a light theme), but why would you?:

    1cb36f15-6b1c-47fe-8b54-4ba44c18aa43-image.png



  • @Matheus-Bitencourt ,

    Was yours an upgrade, or an install? Did you run the installer as Admin, or was it as your normal user?

    Because under some circumstances, the themes (including the default dark theme “DarkModeDefault”) do not get properly installed in %AppData%\Notepad++\themes 🛈. If you go to Settings > Preferences > Style Configurator, click on the Select Theme drop-down, and look for “DarkModeDefault”. If it’s not there, you will have to copy the DarkModeDefault.xml to the right place; there should be a copy at <install directory>\themes\DarkModeDefault.xml, and if you have a normal installation, copy that to %AppData%\Notepad++\themes\DarkModeDefault.xml; otherwise, see “Configuration File Location” in the online usermanual for other possible locations.


Log in to reply