Poor Man's T-SQL Formatter compatibility issue



  • Hi
    I have a windows 10 x64 laptop with NP++ installed (not running the portable version). I had Poor Man’s T-SQL Formatter plugin working till I updated Notepad++ a while ago. Now each time NP++ opens I get the following message:

    https://imgur.com/a/ugbeBEX

    It says that A dynamic link library initialization failed.

    PoorMansTSqlFormatterNppPlugin.dll is not compatible with the current version of Notepad++.

    and then asks me whether I’d like to remove this plugin from the plugins directory.

    whether I choose yes or no the message keeps coming back, plus that Poorman isn’t appearing in the plugins list nor does it appear as installed in the plugin admin window.

    I tried reinstalling both Notepad++ and the plugin but nothing worked

    Any ideas on how to fix this



  • @Omar-Mustafa-Morsi ,

    I just installed Poor Man’s T-SQL Formatter 1.6.13.31508 with a fresh version of Notepad++ v8.1.2 64bit ; it had to install some ancient .NET framework files that I apparently didn’t have on my computer and said I might need to reboot due to .NET changes. The first time I ran Notepad++ after the install, it gave that error. However, I exited Notepad++ and re-ran it, and it loaded fine without error subsequently, even without a reboot.

    Admittedly, mine was in a portable, not an installed copy of Notepad++, but there is no difference between the binary files (or the way that DLLs are loaded), so there is no reason it shouldn’t work on an installed copy.

    Notepad++ v8.1.2   (64-bit)
    Build time : Jul 16 2021 - 01:59:50
    Path : C:\usr\local\apps\npp\npp.8.1.2.portable.x64\notepad++.exe
    Command Line : 
    Admin mode : OFF
    Local Conf mode : ON
    Cloud Config : OFF
    OS Name : Windows 10 Home (64-bit) 
    OS Version : 2009
    OS Build : 19043.1110
    Current ANSI codepage : 1252
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PoorMansTSqlFormatterNppPlugin.dll 
    

    97aa5d82-965e-45e0-bd9f-59dba8bd3cbe-image.png

    You say you’ve tried to re-install the plugin – does that mean you removed it completely and then installed it again? And how did you install it? (Did you use Notepad++'s Plugins Admin?)

    As an experiment, I also tried installing it in a portable v8.1.2 32bit (you said you had 64 bit OS, but not which Notepad++ bitness you used). Since I already had the .NET installed, it didn’t pester me about that; it installed just fine, and even on the first run, it didn’t give the error, and loaded Notepad++ just fine, and the ABOUT box for the plugin shows that v1.6.13.31502 is running (apparently, the 32bit has a different build number in the final digits of the version string)
    15624be7-0d9e-4cb1-9d6a-4f07e4d120c9-image.png

    My guess is that you’ve got an issue with the .NET side of things, so that the plugin cannot load. You might want to reboot. if that’s not enough… Unfortunately, I’m not an expert with that – a quick google led me here, which might be a good starting point for debugging .NET installation problems.



  • @PeterJones thanks for your reply and yes I tried to re-install it using the Plugin Admin

    You’re right I’ve been having some problems with .NET for a while now but didn’t think that it was related