Notepad++ 6.8.7: I can't open .txt files!

  • I installed Notepad++ 6.8.7 to resolve the Save dialog extension issue. However, now I’m having a new (and major) problem: I can’t open .txt files in Notepad++, either by double-clicking a file in Windows Explorer or opening the file from Notepad++'s Open dialog. Can someone please look into this? I’m running Windows 7 Home Premium x64.

  • Hi ToaOfJustice,

    I’m on Windows 7 Profession X64 with notepad 6.8.7 and I don’t have this issue.
    What happens if you double click on txt file? Does any other program start and
    try to open this file?


  • If I double click on a text file, Notepad++ starts, but with a blank document.

  • Did you try another txt file?
    If you have plugins installed, can you start npp without plugins
    and test if problem still exists?
    Can you create a new txt file with npp, close and reopen it?


  • I tried another text file, both with and without plugins. Same problem.

    I was able to create a new text file, but after closing npp, I couldn’t reopen it.

  • Are there some special chars in the text?
    Is there anything unusual in your setup?
    E.g. Running in a virtual environment, working on remote desktop,
    inside a sandbox etc…

    Could it be that you store the file where you
    don’t have read rights? I know sounds strange
    but can be configured.


  • try creating a new user profile on your PC and opening the file from notepad++ logged in there to see if its an issue with the notepad++ settings in your profile. An alternative is to download notepad ++ portable so its not using your local settings. Should help identify where the issue is.

  • @Claudia-Frank There are no special characters in the text. I am not running in a virtual environment, remote desktop, or sandbox. The test file I created and all of my other files are in places where I have read rights.

    @Chris-Johnson I downloaded the portable version of Notepad++ and it was able to open my test file and two other files. Is there a way to reset the preferences of my installed copy of Notepad++?

  • Hi ToaOfJustice,
    as far as i know there isn’t such function.
    What you can do is to copy over the portable version, assuming that
    this is one of the zipped versions from the offical homepage, but this
    would, of course, revert all changes you did.


  • @Claudia-Frank I tried copying over the portable version, but I still ran into the same problem. I solved it by following this procedure:

    1. Uninstall Notepad++
    2. Delete the Notepad++ folder in C:\Program Files (x86)
    3. Associate .txt files with Notepad
    4. Reinstall Notepad++
    5. Associate .txt files with Notepad++

    Thank you for your help, @Claudia-Frank and @Chris-Johnson.

  • Hi all, the problem I have, maybe the same of the others, but allow me to elaborate. I am on Windows 10 running latest version of Notepad++. When I create a normal text file with Notepad++, (save as Normal text file) and I double click to open, I am prompted by Windows asking me what app to open the file with. I am only able to open txt files that are created within windows itself (Right click, select New, select Text Document.

  • Hello Zay Scott,

    you are saying, when creating a txt file with npp you will be prompted by windows if you
    double click on it. When creating a file using the ->New… and double click on it npp
    opens it?
    That sounds weird because windows doesn’t know if it was created using either way.
    Windows uses the extension itself to identify which app needs to be started
    and in which way to open the particular files.
    To make this work you need to register the txt extension with npp app.
    This is normaly done by doing right click on file->properties->
    and press change button at open with line to select npp app.
    Are you using the latest version? Unfortunattely I don’t have windows 10
    so I can’t do any tests maybe someone else has a chance to test this.


  • @Zay-Scott Are you sure that N++ is saving your text file with a “.txt” file extension? I believe there was a somewhat recent change to the Save dialog box, and that new dialog does not actually add the file extension to the file.

    So, if your version of Windows is set up so that file extensions are hidden (one of the worst default behaviors ever to come out of Redmond, IMHO), you won’t see that the “.txt” is missing. If it is missing, however, Windows won’t know what to do with the file when you try to open it…

  • I had the same problem with NPP unable to open TXT files. It would just start with a “new” document when I double-clicked on a .TXT file.

    I am running Win10. I just went back to NPP ver. 6.8.1. Now everything works like it used to. BTW I did not even have to re-do my file extension associations in Win 10. Win 10 remembered them.

    Hope this helps someone.

  • If anyone else runs into this issue or anyone from this thread never figured out what it was, I have a possible solution (it’s what worked for me).

    I was encountering this problem on my work laptop and it migrated across several updates of the software, however I also had a portable version of the npp that i was keeping updated. My work laptop would never open any txt files, like everyone else if I had closed npp, and double clicked the file, they would open the npp application, but it would be with a blank new 1 document. Dragging the file into the window wouldn’t open up a new tab or display the contents of the txt file in notepad no matter what i was able to get done. If I opened one of the portable versions first and left it opened, then I could open up any .txt file i wanted.

    After reading this thread I did a little digging in the preferences, and discovered that in Settings >> Preferences >> MISC there is a setting for Session file ext. and in the text box was TXT, once I removed that and closed npp, double clicked one of the files that I couldn’t open before and BOOM, it opened up in the installed version of npp I had on my laptop, I verified the issue by going back in and adding the TXT into the text field and tried to open the same file, and it wouldn’t open up at all.

  • Hello @MSimcox2

    thank you very much for sharing this and good job figuring this out.


Log in to reply