Starting Compiled Notepad++ generate an Error: load dll

  • Hello, I tried to compile and start notepad ++ to contribute to its development.
    I managed to fill it up but when I started it from these mistakes:
    Check certificate of C:\Users\user\Desktop\notepad-plus-plus-master\PowerEditor\\UnicodeDebug\SciLexer.dll: The specified object can not be found.
    ScintillaEditView::init : SCINTILLA ERROR - Can not load the dinamic library

    I tried to follow the readme file present on github for compile of scilexer.dll but the errors continue to occur.

    Using visualStudio express 2013 with the addition of missing libraries:

    sorry for my english

  • @sambuccid

    for error1 be referred to here
    and regarding error2 two make sure generated SciLexer.dll is in the same folder as notepad++.exe is.


  • First of all thanks for your answer,

    But I did not understand how I can fix the first mistake,
    instead on the second when I come home I look for the generated files and I will delete one.
    I’ll let you know

  • The commit Claudia pointed to makes it so that Notepad++ needs a cryptographically signed SciLexer.dll file. The downside is that you cannot create a signed DLL file, only Don Ho. So the instructions in the readme currently are completely wrong. So you have two options:

    1. Comment out the line of code that checks it, i.e. if (not isCertificateValidated(sciLexerPath, TEXT("Notepad++"))). But you will have to make sure never to commit that change.
    2. Download the official Notepad++ v7.3.3 installer or zip file which contains the signed DLL file and use that instead of building SciLexer yourself. You still have to make sure you put the DLL file in the right place or you will still get the second warning.

  • Ok, thanks for the explanation,
    Do you know what the right place to put the file?
    Otherwise when I have some time looking for it

  • Thanks to everyone, I changed the “SciLexer.dll” file generated by “nmake” with the “ScliLexer.dll” file in the official zip install zip, only that still made the same mistakes, then I put the file in the folder “Unicode Debug” generated by visualstudio that contained the compiled project, then it worked.

    Thank you again to everyone and I hope to be able to contribute to this project

Log in to reply